hi i have just recently brought a 1.3 ford ka collect...


hi i have just recently brought a 1.3 ford ka collection 2004. firstly the engine light has come on and has just remained on now always. I first noticed after the car running for 10 or so minutes stationary a temprature warning light appeared on, and smoke was coming from the passengers side near the rad (under the bonnet) however after 5 minutes of driving the light turned off and the smoke had stopped. since this i have topped up the oil as it was just on the minimum. since this the temp light has not come back on, but the car even when run for 5 mins gets extreamly hot. Also when first started its now taking 3 or 4 attempts to start, with alot of revving or it conks out, once running though its fine. id just like a genuine pointer as to possibilites of what this could be, i havnt long had the car so will take it back for the man to fix as he owns a garage, but want to be sure he doesnt palm me offasilbe using the car alot on the motorways with my 4year old son in the back! it needs to be safe. thankyou ever so much for any advice and sorry this is so long.


Sorry to hear of the problems you are experiencing. There can be a lot of reasons why these problems exist, without examining the car I could not give you any advice. I would recommend booking it into a franchised dealer as they will have fully Ford trained technicians that should be able to give you an accurate diagnosis.

Asked on 03 Jan 2012

Ask a follow up question related to this one

comments powered by Disqus

View more special offers